AWS Aurora PostgreSQL Region Availability.

Getting started with Amazon Aurora global databases.

To get started with Aurora global databases, first decide which Aurora DB engine you want to use and in which AWS Regions. Only specific versions of the Aurora MySQL and Aurora PostgreSQL database engines in certain AWS Regions support Aurora global databases. For the complete list, see Aurora global databases.

You can create an Aurora global database in one of the following ways:

  • Create a new Aurora global database with new Aurora DB clusters and Aurora DB instances – You can do this by following the steps in Creating an Amazon Aurora global database. After you create the primary Aurora DB cluster, you then add the secondary AWS Region by following the steps in Adding an AWS Region to an Amazon Aurora global database.
  • Use an existing Aurora DB cluster that supports the Aurora global database feature and add an AWS Region to it – You can do this only if your existing Aurora DB cluster uses a DB engine version that supports the Aurora global mode or is global-compatible. For some DB engine versions, this mode is explicit, but for others, it’s not.Check whether you can choose Add region for Action on the AWS Management Console when your Aurora DB cluster is selected. If you can, you can use that Aurora DB cluster for your Aurora global cluster. For more information, see Adding an AWS Region to an Amazon Aurora global database.

Before creating an Aurora global database, we recommend that you understand all configuration requirements.

Topics

The Aurora DB clusters that make up an Aurora global database have the following specific requirements:

  • DB instance class requirements – An Aurora global database requires DB instance classes that are optimized for memory-intensive applications. For information about the memory optimized DB instance classes, see DB instance classes. We recommend that you use a db.r5 or higher instance class.
  • AWS Region requirements – An Aurora global database needs a primary Aurora DB cluster in one AWS Region, and at least one secondary Aurora DB cluster in a different Region. You can create up to five secondary (read-only) Aurora DB clusters, and each must be in a different Region. In other words, no two Aurora DB clusters in an Aurora global database can be in the same AWS Region.
  • Naming requirements – The names you choose for each of your Aurora DB clusters must be unique, across all AWS Regions. You can’t use the same name for different Aurora DB clusters even though they’re in different Regions.
  • Capacity requirements for Aurora Serverless v2 – For a global database with Aurora Serverless v2, the minimum capacity required for the DB cluster in the primary AWS Region is 8 ACUs.

Before you can follow the procedures in this section, you need an AWS account. Complete the setup tasks for working with Amazon Aurora. For more information, see Setting up your environment for Amazon Aurora. You also need to complete other preliminary steps for creating any Aurora DB cluster. To learn more, see Creating an Amazon Aurora DB cluster.

Configuration requirements of an Amazon Aurora global database

An Aurora global database spans at least two AWS Regions. The primary AWS Region supports an Aurora DB cluster that has one writer Aurora DB instance. A secondary AWS Region runs a read-only Aurora DB cluster made up entirely of Aurora Replicas. At least one secondary AWS Region is required, but an Aurora global database can have up to five secondary AWS Regions. The table lists the maximum Aurora DB clusters, Aurora DB instances, and Aurora Replicas allowed in an Aurora global database.

DescriptionPrimary AWS RegionSecondary AWS Regions
Aurora DB clusters15 (maximum)
Writer instances10
Read-only instances (Aurora replicas), per Aurora DB cluster15 (max)16 (total)
Read-only instances (max allowed, given actual number of secondary Regions)15 – ss = total number of secondary AWS Regions

RegionAurora PostgreSQL 15Aurora PostgreSQL 14Aurora PostgreSQL 13Aurora PostgreSQL 12Aurora PostgreSQL 11
US East (Ohio)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
US East (N. Virginia)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
US West (N. California)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
US West (Oregon)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
Africa (Cape Town)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
Asia Pacific (Hong Kong)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
Asia Pacific (Hyderabad)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
Asia Pacific (Jakarta)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
Asia Pacific (Melbourne)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
Asia Pacific (Mumbai)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
Asia Pacific (Osaka)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
Asia Pacific (Seoul)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
Asia Pacific (Singapore)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
Asia Pacific (Sydney)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
Asia Pacific (Tokyo)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
Canada (Central)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
Canada West (Calgary)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
China (Beijing)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
China (Ningxia)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
Europe (Frankfurt)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
Europe (Ireland)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
Europe (London)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
Europe (Milan)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
Europe (Paris)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
Europe (Spain)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
Europe (Stockholm)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
Europe (Zurich)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
Israel (Tel Aviv)
Middle East (Bahrain)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
Middle East (UAE)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
South America (São Paulo)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
AWS GovCloud (US-East)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher
AWS GovCloud (US-West)Version 15.2 and higherVersion 14.3 and higherVersion 13.4 and higherVersion 12.8 and higherVersion 11.9 and version 11.13 and higher

Creating an Amazon Aurora global database

Link for Official Doc: Click Here

Leave a Reply

Your email address will not be published. Required fields are marked *